Issue
Customers may find that after upgrading to 2.27.x cannot get Slack Notifications even though it was working previously. This can occur, for example, after setting up Slack notifications in Dinghy
Upon investigating Echo logs, customers may see the following error in Echo:
org.springframework.web.util.NestedServletException: Handler dispatch failed; nested exception is java.lang.NoSuchMethodError: 'void org.jsoup.select.NodeTraversor.<init>(org.jsoup.select.NodeVisitor)'
with a further reference to:
Caused by: java.lang.NoSuchMethodError: 'void org.jsoup.select.NodeTraversor.<init>(org.jsoup.select.NodeVisitor)'
Cause
The issue was caused by recent upgrades to the jinjava
package in Spinnaker, which caused an issue with a dependency in jsoup.
Solution
The issue is targeted for resolution in Armory Enterprise 2.28.0
.
Hotfix
Before the release of these versions, customers can ingest a Hotfix that has been published.
Administrators need to add the following artifactId
in the appropriate location according to the following KB article on using Hotfixes: https://support.armory.io/support?id=kb_article_view&sysparm_article=KB0010085
The artifactID change should be placed in either .hal/<defaultProfile>/service-settings/echo.yml
in Halyard
or spec.spinnakerConfig.service-settings.echo.artifactId
in Operator
artifactID for Echo:
artifactId: armory/echo-armory:2022.03.17.19.30.11.release-2.27.x
As Tested On Version
2.27.x